pancakes

MicrostockGroup Sponsors


Author Topic: Payment running through fine - but no image is devilered  (Read 1250 times)

0 Members and 1 Guest are viewing this topic.

Spectral-Design.net

« on: August 26, 2013, 08:55 »
+1
Hi all,

Finally I am starting with my symbiostock website. Until now everything is going well and the only thing left to get to run before mass uploading is the payment - and here is where the problem lies:

1. A friend is paying for a image. Paypal works perfectly...the money is coming through as well as the emails. But after returning to the site no image appears in the customer area to be downloaded.
Off course I read a bit here and on other sites and sometimes the problem seems to be associated with plugins like bad-behaviour, but I have none of those installed.
The only thing I get is: Items still in your cart, and not in your download area?
Wait a few seconds and refresh the page. Sometimes paypal takes a few minutes to notify us. If you still have problems, please contact us."

Anyone could help me out with this?

Thanks....


« Reply #1 on: August 26, 2013, 09:26 »
0
The person in this thread is having the same issue:


http://www.microstockgroup.com/symbiostock-technical-support/
issues-with-download-after-paying-with-paypal-for-file/

But i dont see that it ever got resolved. Hopefully someone who knows the answer
will help and maybe publish publicly so everyone can see how to fix.
You might try pm-ing leo...maybe he can help.

Spectral-Design.net

« Reply #2 on: August 26, 2013, 09:40 »
0
The person in this thread is having the same issue:


http://www.microstockgroup.com/symbiostock-technical-support/
issues-with-download-after-paying-with-paypal-for-file/

But i dont see that it ever got resolved. Hopefully someone who knows the answer
will help and maybe publish publicly so everyone can see how to fix.
You might try pm-ing leo...maybe he can help.


Thank you Cathy...I hope there is some solution to that...lets see if Leo has some Idea....

Spectral-Design.net

« Reply #3 on: August 26, 2013, 10:27 »
0
Mmmmm....I guess there is some Problem with the IPN. When trying to call through a Browser domain.com/symbiostock_ipn/index.php it gives me a server error 500...

PhilD

  • Never met any BBQ I didn't like.
« Reply #4 on: August 26, 2013, 10:31 »
0
Sounds like maybe your SYS installation is blocking PayPal's IPN server.  You can check in your PayPal account if it successfully passed the info to your site.  If it hasn't it will show that it's continuing to try which is a sign that something in your SYS site (likely a plug-in) is blocking the PayPal server.

If your PayPal and SYS IPN setup is OK, etc.  I'd then Deactivate all active plug-ins except the Symbiostock email and notification plug-in and see if that helps.


Spectral-Design.net

« Reply #5 on: August 26, 2013, 10:44 »
0
Sounds like maybe your SYS installation is blocking PayPal's IPN server.  You can check in your PayPal account if it successfully passed the info to your site.  If it hasn't it will show that it's continuing to try which is a sign that something in your SYS site (likely a plug-in) is blocking the PayPal server.

If your PayPal and SYS IPN setup is OK, etc.  I'd then Deactivate all active plug-ins except the Symbiostock email and notification plug-in and see if that helps.

Thanks Phil...I did some testing in the Paypal sandbox and it gives me:
IPN Delivery Failed:500 Internal Server Error

I have no Idea where this 500 comes from. The file permissions are set ok and in WP I have no sec plugion of any kind installed....checking the server side now...

« Reply #6 on: August 26, 2013, 11:24 »
0
Some of us did not manage to get the sandbox set up at all and went straight to live  ::)

Did your "buyer" get an email with an acknowledgement of the sale, a thumbnail of the picture they bought and a download link - you should also have had a copy of this?

« Reply #7 on: August 26, 2013, 11:28 »
0
I was never able to get sandbox working correctly, so i dont have any advice there...i just went live when i was pretty well set up and all worked without a hitch.


There are a couple of recent threads about ipn issues. I would copy and paste, but on my ipad it breaks this window. Check those out and see if you can find some tips from those.


Basically, you dont need to add any ipn settings in paypal at all...in fact dont even enable ipn. Are you using 2.5.6? If not, maybe update. There is a thread with a link where to download that...i created it. Look in the Sy - technical support section for these threads.

Spectral-Design.net

« Reply #8 on: August 26, 2013, 11:36 »
0
RESOLVED!

Stupid me!  :-[ I got a new server for the symbiostock site and haven`t had installed curl and some other php modules yet. The Apache log illuminated my obscure mind and three ssh lines later paypal got through and the images available to download :-)

If you ever see a line like...
"[date] [warn] [client xxx.xxx.xxx.xxx.] mod_fcgid: stderr: PHP Fatal error:  Call to undefined function curl_init() in /home/yoursite/public_html/symbiostock_ipn/paypal_ipn.php on line 39"
...in your logs you know now what the solution is :-)

Thanks everybody!
« Last Edit: August 26, 2013, 11:40 by Spectral-Design.net »

« Reply #9 on: August 26, 2013, 12:21 »
0
Cool, glad you figured it out.

Spectral-Design.net

« Reply #10 on: August 26, 2013, 12:27 »
0
Cool, glad you figured it out.

Thanks Cathy :-)

« Reply #11 on: August 26, 2013, 12:50 »
0
So am I - not something I would have thought of - nor understand  ;D


 

Related Topics

  Subject / Started by Replies Last post
28 Replies
9372 Views
Last post October 12, 2007, 18:23
by wingedcats
8 Replies
1294 Views
Last post April 03, 2013, 08:06
by Microbius
6 Replies
4572 Views
Last post July 01, 2013, 08:29
by jcpjr
2 Replies
654 Views
Last post August 02, 2013, 01:16
by johnmessingham
3 Replies
1059 Views
Last post February 05, 2018, 09:15
by increasingdifficulty

Sponsors

Microstock Poll Results

Sponsors