MicrostockGroup Sponsors


Author Topic: Login Problems at iStock  (Read 4219 times)

0 Members and 2 Guests are viewing this topic.

« on: March 15, 2010, 07:04 »
0
I haven't been able to login to iStock for over 24 hours.   Consequently, the iStock stats in the picNiche toolbar are not working either.  I have tried many times to login.  This has never happened before.  Is anybody else experiencing the same problem?

Every time I try to login, the white login box appears, and the following message displays:

The connection has timed out
                       
The server at secure.istockphoto.com is taking too long to respond.
             
    *   The site could be temporarily unavailable or too busy. Try again in a few
          moments.

    *   If you are unable to load any pages, check your computer's network
          connection.

    *   If your computer or network is protected by a firewall or proxy, make sure
          that Firefox is permitted to access the Web.


« Reply #1 on: March 15, 2010, 07:48 »
0
No, no problem here, either FireFox or IE.  I've been logged in all morning.

« Reply #2 on: March 15, 2010, 08:19 »
0
Same here !  No probs !!   :D

« Reply #3 on: March 15, 2010, 08:53 »
0
I was able to log in, but it seems kind of slow.

« Reply #4 on: March 15, 2010, 16:07 »
0
Logged in without problems.

« Reply #5 on: March 15, 2010, 16:23 »
0
This is my guess because it happened to me before both at IS and DT.

Did it happen after the daylight saving time become effective? if so, it is possible that your computer time was not correctly set. Hope it helps.

« Reply #6 on: March 15, 2010, 17:13 »
0
try clearing your cache? And/or if you are using windows be sure you have all the latest security updates installed?

« Reply #7 on: March 15, 2010, 18:55 »
0
After they introduced their new, simpler, faster login process,  login got slower.  :)     

Sometimes I've had the login screen (with the image of the guy painting a wall) hang, but if I kill the whole window and then go back to IS I find I'm logged in.  I don't think it works well with Opera, in case that's what you're using.

« Reply #8 on: March 15, 2010, 19:01 »
0
Thank you all for your comments, suggestions and help.

I took notice of your suggestions.......clearing my cache didn't help.   However, I installed all of the available updates for Windows, then turned my modem off, and restarted everything, now it's working fine!


Cheers

Phil


 

Related Topics

  Subject / Started by Replies Last post
istock login problems

Started by stacey_newman iStockPhoto.com

4 Replies
4630 Views
Last post April 04, 2009, 11:12
by stacey_newman
5 Replies
2738 Views
Last post April 16, 2014, 03:39
by JoeClemson
3 Replies
1130 Views
Last post February 22, 2017, 16:26
by Minsc
1 Replies
2513 Views
Last post January 21, 2018, 21:03
by Niakris
1 Replies
1446 Views
Last post March 11, 2019, 13:20
by Niakris

Sponsors

Mega Bundle of 5,900+ Professional Lightroom Presets

Microstock Poll Results

Sponsors

3100 Posing Cards Bundle