pancakes

MicrostockGroup Sponsors


Author Topic: Epson printer driver woes  (Read 2648 times)

0 Members and 1 Guest are viewing this topic.

ShadySue

« on: November 15, 2012, 06:28 »
0
In however long I've been using computers, I've never had this problem. Printer drivers have installed first time and lasted until either the printer or the computer expired.

I have an Epson stylus photo 1400 printer. I used it with my last computer, and on this computer without any driver problems until a couple of months back.

Suddenly, when I wanted to print anything, no matter how simple, it took about 20 minutes between pressing print and the printer even starting. Even with a very basic, short Word file.

It seemed that the Epson printer driver had just disappeared from my computer, without me doing anything. Presumably some system or software upgrade (?).

So I downloaded what purported to be the Epson driver from their website. It didn't look or work like the Epson driver I got or the CD, but at least it printed just after I hit 'print', but only for plain print. I have no options in PS to print on glossy paper or do any tweaks, etc.

So yesterday, as I need to print out a proper photo, I went back to Epson and tried to download a driver. It kept telling me that the printer was not connected to the computer. This is patently untrue, as both before and after getting the 'not connected' message, I could still print out simple documents on plain paper, out of Word or Photoshop. (Have no idea what driver it's using, as the proper driver isn't showing anywhere, and although the printer ink drop is flashing, I'm not getting the on screen message. I've stopped and started the printer, plugged the USB cable into a diferent USB socket when prompted etc.

Surprisingly, I found the original printer CD, and this morning when I switched on the computer, I started again from the CD. After several rounds of trying, I fired up PS, only to save screenshots of what messages I'm getting. (the instructions say not to have any other apps running, and I just wanted to make clear I didn't have PS running for a few times I was trying.

So here's what I'm getting when trying to install from CD:

and this is the next screen:

Hitting the problem solver leads to just a blank pale blue page.
If I go back to the beginning and choose custom install, I very quickly get this:

Clicking manual gives me a lot of ports to choose from, none of which seem relevant (but WDIK?) and hitting cancel takes me out of the whole installation process.

Trying to install from a downloaded exe from Epson's site just gets me to the second and third image above. Online,the problem solver just tells me to connect the computer to the USB, no more suggestions.
Yes, I am taking the USB out before I start and putting it in when I get the prompt, and I've tried two different USB ports. Note as above that the printer does work, it's not like something is dead.

Any suggestions before I go onto live help? (I've not had much luck with anyone else's live help - they always seem to stick rigidly to a 'script' that doesn't match my problem.)

TIA

Any suggestions before I throw myself at the mercy


« Reply #1 on: November 15, 2012, 07:12 »
0
What OS are you using?
If it's on Windows try uninstalling the driver completely before re-installing.
Could be an automatic update screwed things up. Look to see what updates have been made and restore to an earlier time?

ShadySue

« Reply #2 on: November 15, 2012, 08:27 »
0
What OS are you using?
If it's on Windows try uninstalling the driver completely before re-installing.
Could be an automatic update screwed things up. Look to see what updates have been made and restore to an earlier time?

Well, yeah, except that there was no Epson driver showing and apparently I was printing via 'Send to OneNote 2010'. And I've had so many Java upgrades (perpetual, it seems) etc that was going to be difficult.
However, your suggestion worked to a degree. I uninstalled everything that started with Epson, then used the CD again. Whoopee, it said the printer driver had installed. Had to reboot, then PS gave me an error message, "The saved printer information is not compatible with this version of Photoshop, or the saved printer is no longer available. You will need to check your printer settings before printing" which I've been getting intermittently.
However, the Epson driver was now listed in devices and printers, , and some of the functions are now available, including choosing paper type and size (but the ink cartidge monitor is blank). So as I didn't need the print for a competition, I used some ancient WHSmith Photo paper and the print was fine. But ha! I'm so used to Epson Premium Glossy being instantly touch try that I managed to get the tip of a thumbprint on the print and had to do it again!

Thanks. Got me out of a hole, and I'll be the blue-eyed girl once more.  ;D

« Reply #3 on: November 15, 2012, 09:18 »
0
I had trouble with an Epson on XP. I used to end up with a sort of generic print driver sometimes.
I knew I'd seen this somewhere
http://support.microsoft.com/kb/81626
There also seem to be a lot of problems in general printing from Photoshop. I don't use it so I can't help there. I don't print much but I generally print from Windows photo viewer. Not a great program, and no use if you're using colour profiles, but OK to just get a print to see.

EmberMike

« Reply #4 on: November 15, 2012, 09:38 »
0

After over a decade of nothing but Epson printers, I gave up. Their software has gotten worse and worse recently. I had to switch over to Canon.


ShadySue

« Reply #5 on: November 15, 2012, 09:42 »
0
I've been printing out of PS for years (since PS7), with no problems. I haven't got a proper tight colour system set up, because I don't need to be totally accurate - so long as it generally 'looks OK', skin tones look good and there isn't a colour cast on monos, I'm fine. I find the paper makes as much difference as anything.

ShadySue

« Reply #6 on: November 15, 2012, 09:43 »
0

After over a decade of nothing but Epson printers, I gave up. Their software has gotten worse and worse recently. I had to switch over to Canon.

Funnily I was about to say I found Epson printers better than Canon, but to be fair, my last two printers were Epson (1250 then 1400) so I haven't used any recent Canon printers.

« Reply #7 on: November 15, 2012, 09:57 »
0
Like most things to do with computers if you look at any of the printer manufacturers then someone has had a problem with drivers. I've got a feeling that printers are more complicated to get right than most hardware. Scanners seem to be another problem. I've changed scanners twice now because of a lack of support for a new OS. There again I don't use a scanner for anything much more critical than copying the occasional document.

« Reply #8 on: November 15, 2012, 10:20 »
0
When I upgraded last summer my Xerox woudldn't work properly, I literally went out of my mind trying to install drivers and to find help.  I must have spent a good 2 days solid trouble shooting, so I had to plug in my Brother and use it.  About 2 weeks later I turned on my computer and a message popped up "your printer drivers have been updated sucessfully".  I felt kind estatic but angry at the same time.  I swear there are little fairies running around running the joint and playing silly tricks!

RacePhoto

« Reply #9 on: November 26, 2012, 11:40 »
0
Problem is, you shouldn't have to install any software or drivers, the computer should recognize the printer and do that automatic. Epson is the standard of the industry. (in other words, many others are using Epson printer drivers for their printers and have since daisy wheels)

You mean when you uninstall all the printer drivers for that printer and just plug it in, Windows doesn't say New Device Found and install the drivers?

What OS? I didn't catch that part. Up to and including XP things worked, then Microsoft screwed all of us and from Vista on, many "legacy" printers aren't supported anymore. For that reason I keep using XP and have never upgraded, but I may be forced to soon as the newer editing software needs more than the limit 3GB that XP can access.


 

Related Topics

  Subject / Started by Replies Last post
11 Replies
4051 Views
Last post June 20, 2006, 17:47
by madelaide
86 Replies
17614 Views
Last post March 06, 2008, 16:05
by thesentinel
0 Replies
1664 Views
Last post November 04, 2008, 01:05
by RH
9 Replies
3310 Views
Last post February 09, 2009, 14:26
by ichiro17
0 Replies
508 Views
Last post October 08, 2018, 11:10
by nobody

Sponsors

Microstock Poll Results