MicrostockGroup Sponsors

Envato Elements

Author Topic: problems with Shutterstock model authorization  (Read 258 times)

0 Members and 1 Guest are viewing this topic.

« on: April 11, 2019, 12:25 »
0
I posted a few days ago fitness photos with authorization of models without problems, this week I uploaded a few more of the same session and with the same model authorization and I rejected them because it says "not valid model authorization": One or more of the attached model authorizations do not meet our requirements.
this only in shutterstock (istock and adobe without problems) to someone else has it happened?


« Reply #1 on: April 11, 2019, 20:44 »
+2
It happens all the time. SS reviewers are inconsistent. Try again.

« Reply #2 on: April 12, 2019, 11:07 »
+1
It's a recurring problem, it happens to me all the time and there's no logic. Once again last week I have the first part of a series that has been accepted without any problem and this week the photos of the same series with the same release model are refused "not valid model authorization".  No need to contact a moderator the last time I did it I got an answer after about ten days telling me that I needed to attach a "valid model authorization" I think he hadn't even read my explanations. Since then I send my images back several times if necessary and they end up being accepted. It's a huge waste of time, but I don't have any other solution to propose. :(


 

Related Topics

  Subject / Started by Replies Last post
3 Replies
2336 Views
Last post March 26, 2006, 00:06
by Freezingpictures
6 Replies
3601 Views
Last post October 04, 2006, 01:12
by leaf
10 Replies
4712 Views
Last post February 27, 2007, 03:06
by sharpshot
11 Replies
3226 Views
Last post July 30, 2008, 03:33
by josh_crestock
3 Replies
1361 Views
Last post February 20, 2013, 18:12
by Walpurgis

Sponsors

Microstock Poll Results