pancakes

MicrostockGroup Sponsors


Author Topic: Shutterstock "Losing" Model Releases?  (Read 695 times)

0 Members and 1 Guest are viewing this topic.

wds

« on: April 02, 2020, 17:06 »
0
I have had a number of submissions where I know I attached a model release and SS is claiming I did not....have other's seen that?


angelawaye

  • Eat, Sleep, Keyword. Repeat

« Reply #1 on: April 02, 2020, 19:35 »
0
I haven't had that happen but they are saying all of a sudden a model release is "invalid" which is frustrating.

wds

« Reply #2 on: April 02, 2020, 21:31 »
0
I have seen both on different files: claiming a model release isn't there when I know I uploaded one, and that a model release is invalid....what is going on there ?!?!?

wds

« Reply #3 on: April 03, 2020, 08:57 »
+1
I haven't had that happen but they are saying all of a sudden a model release is "invalid" which is frustrating.

Yes, and of course they won't tell you what is "invalid" about it so you can't address or contest the issue.

« Reply #4 on: April 03, 2020, 13:14 »
0
I haven't had that happen but they are saying all of a sudden a model release is "invalid" which is frustrating.

It happened to me several times.

wds

« Reply #5 on: April 06, 2020, 14:16 »
0
I haven't had that happen but they are saying all of a sudden a model release is "invalid" which is frustrating.

It happened to me several times.

Out of curiosity, are the model release rejections from older shoots?

angelawaye

  • Eat, Sleep, Keyword. Repeat

« Reply #6 on: April 07, 2020, 08:46 »
0
Mine was an old one but then I did an updated release and made sure everything was neat and legible and filled out to perfection, they accepted it on an image uploaded on Saturday and rejected it yesterday on another image! So apparently model releases are hit and miss ... They are good one day of the week, then not good (then probably good again).

wds

« Reply #7 on: April 07, 2020, 10:37 »
0
Mine was an old one but then I did an updated release and made sure everything was neat and legible and filled out to perfection, they accepted it on an image uploaded on Saturday and rejected it yesterday on another image! So apparently model releases are hit and miss ... They are good one day of the week, then not good (then probably good again).

Interesting. I was speculating that maybe they were not accepting older (whatever that my mean) releases. I guess it's not so simple.

Uncle Pete

  • Great Place by a Great Lake - My Home Port
« Reply #8 on: April 08, 2020, 10:55 »
0
Mine was an old one but then I did an updated release and made sure everything was neat and legible and filled out to perfection, they accepted it on an image uploaded on Saturday and rejected it yesterday on another image! So apparently model releases are hit and miss ... They are good one day of the week, then not good (then probably good again).

Interesting. I was speculating that maybe they were not accepting older (whatever that my mean) releases. I guess it's not so simple.

While SS is unpredictable and insane, all my releases on IS (almost all) changed to "must have models date of birth" but the system allowed me to add that data.

SS being insane, what I mean is, a release is good one day, not the next and maybe a week later, good again. The lost release, not attached Etc. I thought was me forgetting to check something or messing up when editing. Now I'm starting to think, it's just the system has some flaws and actually loses the checked attachment. I'll never know, but yes it has happened to me too.


 

Related Topics

  Subject / Started by Replies Last post
2 Replies
3272 Views
Last post June 20, 2016, 15:28
by nicksimages
0 Replies
1457 Views
Last post July 02, 2017, 00:34
by Chichikov
11 Replies
2776 Views
Last post November 09, 2018, 11:40
by derek
2 Replies
1391 Views
Last post May 20, 2018, 22:46
by unnonimus
8 Replies
1472 Views
Last post May 13, 2019, 19:42
by helloitsme

Sponsors

Mega Bundle of 5,900+ Professional Lightroom Presets

Microstock Poll Results

Sponsors

3100 Posing Cards Bundle