MicrostockGroup Sponsors


Author Topic: Releasing my First Symbiostock Child Theme  (Read 23266 times)

0 Members and 1 Guest are viewing this topic.

« Reply #50 on: May 23, 2013, 02:50 »
0
Hi Amanda

I use All Images as a check for me to make sure I have the same number of images categorised as I do listed, added this category when I first started and has been useful, might get too unwieldy at some point but still works at the moment.

Did you get chance to look at the css I sent you?


« Reply #51 on: May 23, 2013, 05:35 »
0
I used to add just the IMAGE keyword after the URL and it
shows me the ALL IMAGES.

It has been working in 1.3.7 and is working in 2.0.

Just check it out, straight from the box http://stock.imagerion.com/image/

After you click any image you can see it's not in any ALL IMAGES category

« Reply #52 on: May 27, 2013, 07:22 »
0
I'm still using old version, but not for long time. Clean theme runs ok with new SY release?

« Reply #53 on: May 27, 2013, 08:04 »
0
I'm still using old version, but not for long time. Clean theme runs ok with new SY release?


I lost all my custom css in clean theme editor window. I might suggest you copy and save that somewhere before updating, just in case.

edit: just to be clear, all the changes I made in the Edit CSS window, to the Clean Theme CSS, disappeared.
« Last Edit: May 27, 2013, 08:37 by cclapper »

« Reply #54 on: May 27, 2013, 08:53 »
0
I'm still using old version, but not for long time. Clean theme runs ok with new SY release?


I lost all my custom css in clean theme editor window. I might suggest you copy and save that somewhere before updating, just in case.

edit: just to be clear, all the changes I made in the Edit CSS window, to the Clean Theme CSS, disappeared.

Thanks!! I'll do some copys before upgrade.

« Reply #55 on: May 27, 2013, 10:42 »
0
I'm still using old version, but not for long time. Clean theme runs ok with new SY release?


I lost all my custom css in clean theme editor window. I might suggest you copy and save that somewhere before updating, just in case.

edit: just to be clear, all the changes I made in the Edit CSS window, to the Clean Theme CSS, disappeared.

Thanks!! I'll do some copys before upgrade.

Yes, do, for sure. I can confirm that loading 2.2.7 does indeed delete css from edit css window...somehow my footer got messed up when I was working on my latest images/featured images area, so I reloaded 2.2.7 and the Clean Theme to straighten that out (it did) and the css was MIA again.  :(

« Reply #56 on: May 27, 2013, 14:43 »
0
Well.. I use the Child Theme since the beginning, have a lot of customizations and more than just css - nothing happens after updates.
I click update  then activate child theme back and everything works ok, all files stay in the child folder untouched.

« Reply #57 on: May 27, 2013, 15:12 »
0
plrang, I think you are talking about the default child theme, you are correct that would not be affected.  This thread is referring to a custom child theme called Clean Theme.

If you have Jetpack installed on your site you can customize a theme or child theme by adding CSS, I've done a tutorial here: http://www.creativembers.com/customizing-a-symbiostock-child-theme/ but as noted, you should always save a back up of your CSS edits.  These can just be pasted into a text file locally, but as with the main site the number one rule when dealing with web stuff is back up everything you can.

I haven't installed the newest version yet but I plan to upgrade the Clean Theme test site to 2.2.8 tomorrow and get to work on a few improvements.  I put the development on hold until we are out of Beta since things were changing so quickly.

Cathy, sorry for your trouble with the custom stuff getting deleted.  I checked you site just now and it looks good, I guess you got it all put back?  I'm curious as to what you are changing since I am considering adding a color picker to the admin panel. Can you send me a quick note when you get a chance and let me know?

« Reply #58 on: May 27, 2013, 15:16 »
0
Oh ok, sorry, I understand, I removed that Jetpack anyway for speed and to be independent by using the child theme. Just for information

« Reply #59 on: May 27, 2013, 17:02 »
0

I haven't installed the newest version yet but I plan to upgrade the Clean Theme test site to 2.2.8 tomorrow and get to work on a few improvements.  I put the development on hold until we are out of Beta since things were changing so quickly.


Good news. So, I'll wait. Thanks.

« Reply #60 on: July 11, 2013, 10:04 »
0
Hello Amanda, I just upgraded to your Clean Theme 2.0, looks good! Just one thing I cant figure out... even if I am logged in I cant access the dashboard anymore. I cant logout either?

« Reply #61 on: July 11, 2013, 12:30 »
0
Hi Tina,

Clean theme hides the admin bar so that customers don't see the Wordpress elements of your site when they are logged in.  I can help you take this function out if you'd rather have the admin bar/dashboard link showing. 

Can you tell me what happens when you log out?  I'm not having that issue on the demo site so I'm not sure what could be causing that for you.  I have emailed you version 1.0 to test per your request. 

« Reply #62 on: July 11, 2013, 12:40 »
0
Update: Looking into Tina's issue I can see there may be a bug with one of the newer files and the log-in/log out function.  If you are 1.0 you can stay there for now while I update one more file and re-send 2.0.  Sorry for any inconvenience!

« Reply #63 on: July 11, 2013, 14:35 »
0
Thanks for fast answer Amanda, yes I would like to keep the admin-bar if possible. I made you as administrator in my site. Perhaps my site is good for doing some testing too, I dont know.. I am totally newbie

« Reply #64 on: July 11, 2013, 15:04 »
0
Tina, I sent you a fix via email (2.0.1) that I am 99% sure clears up the issue.  I have two others testing now, once they give me the all clear I'll be sending it out to everyone else.  Thank you!

Edit: you are all set as far as I can see, I logged in and made the change for you so your admin bar should show up!  I'll add a tutorial on that in case anyone else would like to change it. 
« Last Edit: July 11, 2013, 15:22 by Amanda_K »

« Reply #65 on: July 11, 2013, 15:43 »
+1
Thanks Amanda. I got the admin-bar back, and no other problems  ;D

« Reply #66 on: August 25, 2013, 07:30 »
0
Hi Amanda, I have purchased the Clean Theme, installed it but there is nothing different by SY child theme, I cane see the layout of my site in the same way. The Demo I saw for the Clean theme was a different thing. I have the same layout like the main Child theme for Symbiostock. No difference. You can see it here: www.stockphotos.ezeepics.com CAN YOU HELP ME PLEASE?

« Reply #67 on: August 25, 2013, 09:12 »
0
Hi Amanda, I have purchased the Clean Theme, installed it but there is nothing different by SY child theme, I cane see the layout of my site in the same way. The Demo I saw for the Clean theme was a different thing. I have the same layout like the main Child theme for Symbiostock. No difference. You can see it here: www.stockphotos.ezeepics.com CAN YOU HELP ME PLEASE?


Did you go to Appearance>Themes in your dashboard on the left and activate Child Theme 2.0, which will automatically deactivate the SY theme? It looks like, from your link above, that you have the Twenty Thirteen theme activated. Your theme page should look like this:
« Last Edit: August 25, 2013, 09:14 by cathyslife stockphotos.com »

« Reply #68 on: August 25, 2013, 09:27 »
0
The Clean Theme was activated earlier - you can tell the difference as Amanda's theme has a narrow footer and everything is neatly contained with a grey background.  With the basic child theme you have a wide footer (if anyone has found a way of making this match the rest of the page I would be delighted to hear from you) and you do not get the grey background around the edges.

« Reply #69 on: August 25, 2013, 10:04 »
0
Hi Amanda, I have purchased the Clean Theme, installed it but there is nothing different by SY child theme, I cane see the layout of my site in the same way. The Demo I saw for the Clean theme was a different thing. I have the same layout like the main Child theme for Symbiostock. No difference. You can see it here: www.stockphotos.ezeepics.com CAN YOU HELP ME PLEASE?


Did you go to Appearance>Themes in your dashboard on the left and activate Child Theme 2.0, which will automatically deactivate the SY theme? It looks like, from your link above, that you have the Twenty Thirteen theme activated. Your theme page should look like this:


Yes Cathy, I did exactly this....Now you see the Thirteen becuase I updated Symbiostock from 2.5.5 to 2.5.6 and I got again white screen and couldn't access my Dashboard. So I was forced to remove Symbiostock from File Manager in order to be able to access the Dashboard again. Now I'm waiting for Leo to fix it again, I hope I will not get this white screen every time I make an update, is annoying....

« Reply #70 on: August 25, 2013, 10:32 »
0
Hi Amanda, I have purchased the Clean Theme, installed it but there is nothing different by SY child theme, I cane see the layout of my site in the same way. The Demo I saw for the Clean theme was a different thing. I have the same layout like the main Child theme for Symbiostock. No difference. You can see it here: www.stockphotos.ezeepics.com CAN YOU HELP ME PLEASE?


Did you go to Appearance>Themes in your dashboard on the left and activate Child Theme 2.0, which will automatically deactivate the SY theme? It looks like, from your link above, that you have the Twenty Thirteen theme activated. Your theme page should look like this:


Yes Cathy, I did exactly this....Now you see the Thirteen becuase I updated Symbiostock from 2.5.5 to 2.5.6 and I got again white screen and couldn't access my Dashboard. So I was forced to remove Symbiostock from File Manager in order to be able to access the Dashboard again. Now I'm waiting for Leo to fix it again, I hope I will not get this white screen every time I make an update, is annoying....


Oh, okay, sorry. Yes, I wish Leo would post what the fix is for everyone to see, instead of just going into your website and changing it. Especially if it keeps happening on every update.

« Reply #71 on: August 25, 2013, 12:46 »
0
With the basic child theme you have a wide footer (if anyone has found a way of making this match the rest of the page I would be delighted to hear from you) and you do not get the grey background around the edges.

I use use the basic child theme and I simply set the border to 0.

Code: [Select]
footer .footer_info {
background-image: none;
background-color: #fff;
text-align: center;
border: 0
}

« Reply #72 on: August 25, 2013, 13:31 »
0
CleanTheme (or any other child theme) will change the styling of your site, such as fonts, colors some spacing and it may occasionally move a few elements around on the page. 

It will not create new content or install any plugins so you are still free to build your home page to look any way you want.  If you want a home page with a slider you will need to make sure you are creating and setting a static home page (probably using the Home Page CTA template)  in WordPress instead of defaulting to the blog page.

There are many threads on setting up your home page and which plugins and widgets people are using.  I hope to have time to do a full tutorial on this soon at Symbioguides.  In the meantime, here is a thread where Chico shared a marked up screen shot of the home page structure:
http://www.microstockgroup.com/19164/19164/msg316106/#msg316106

If you read through that post and the others in that thread is should give you a good starting point.


« Reply #73 on: August 25, 2013, 14:05 »
0
CleanTheme (or any other child theme) will change the styling of your site, such as fonts, colors some spacing and it may occasionally move a few elements around on the page. 

It will not create new content or install any plugins so you are still free to build your home page to look any way you want.  If you want a home page with a slider you will need to make sure you are creating and setting a static home page (probably using the Home Page CTA template)  in WordPress instead of defaulting to the blog page.

There are many threads on setting up your home page and which plugins and widgets people are using.  I hope to have time to do a full tutorial on this soon at Symbioguides.  In the meantime, here is a thread where Chico shared a marked up screen shot of the home page structure:
http://www.microstockgroup.com/19164/19164/msg316106/#msg316106

If you read through that post and the others in that thread is should give you a good starting point.


Thank you Amanda, I will take a look after Leo will fix my Symbiostock, I have again blank page problem.
Have a nice day,

« Reply #74 on: August 25, 2013, 14:38 »
0
It is still showing 2013 for me, not a blank page

~~

Thanks Redneck, will try that


 

Related Topics

  Subject / Started by Replies Last post
4 Replies
2900 Views
Last post March 30, 2013, 03:28
by Kerioak~Christine
43 Replies
9758 Views
Last post July 10, 2013, 20:38
by cathyslife
3 Replies
2153 Views
Last post April 30, 2013, 03:51
by Kerioak~Christine
31 Replies
8529 Views
Last post June 09, 2013, 17:14
by cascoly
1 Replies
2598 Views
Last post September 14, 2013, 16:50
by DallasP

Sponsors

Mega Bundle of 5,900+ Professional Lightroom Presets

Microstock Poll Results

Sponsors