MicrostockGroup Sponsors


Author Topic: How to setup "Newest" and "Featured" images on the home page?  (Read 12951 times)

0 Members and 1 Guest are viewing this topic.

« on: April 27, 2013, 18:46 »
0
I feel so stupid.

I've gone through several threads but cannot get it to work.

First off I think I have a problem with defining what is my home page.

In the Wordpress control panel I goto "Appearance" -> "Themes" -> Symbiostock "Customize" and in the left menu at the bottom I set my front page to be a static page that used to be my home page which is static but I want it be more dynamic.

So... that's the first issue. Then I try to drag the widgets (Newest and Feature") into any of the areas on the right and try to check my front page but nothing happens  >:(

Are there any tutorials out there already or what do I have to do to get a front page that showcases:

1. row: feature images

2. row: newest images

display a pre-configured page with some welcome message etc.

Thanks in advance!


« Reply #1 on: April 27, 2013, 19:14 »
0
From my trial and error, I think you can only use the home page CTA template if you want to use those widgets. I managed to get the Latest Images to show up in a right sidebar, but that isnt what I wanted. (sorry, I don't remember which template I used for that.)

Hopefully someone else will come along with a little more knowledge on that.

edit: I was wrong about the home page CTA and widgets...see below
« Last Edit: April 27, 2013, 19:21 by cclapper »

« Reply #2 on: April 27, 2013, 19:20 »
0
Here's a screen shot of a post Leo made in one of the threads, explaining which template works with the widgets. Maybe it will help you figure it out?

« Reply #3 on: April 27, 2013, 19:31 »
0
Thanks cclapper but I don't understand the image  :-[

I must have some mental block going on right now. Where do I get the CTA template or any of the other templates?

« Reply #4 on: April 27, 2013, 20:13 »
0
Open your page. On the right side column, about halfway down, it says what template is assigned to that page and you can change that. So if you change to home page cta, per my image, there will be two content boxes first, then you can use a full width widget, etc. (im going from memory...only on my ipad now).


I know its very confusing. Trust me, i know. I just kept changing the page template to see what each one did. I couldn't really find the exact combination that i wanted so i settled on what i have now. I am concentrating on uploading images, then i will go back and try some artsy-fartsy stuff.

« Reply #5 on: April 27, 2013, 20:29 »
0
Look at post 6 where Leo links to a video that describes the process.

http://www.microstockgroup.com/symbiostock-technical-support/menu-missing-on-mobile-devices-and-smaller-screens/msg310925/#msg310925

I had asked the same question as you have.


« Reply #6 on: April 27, 2013, 20:42 »
0
Great, thank you! I'm watching it now!

« Reply #7 on: April 27, 2013, 21:05 »
0
In the video: http://www.symbiostock.com/free-files/widgets_and_menus.swf

at the 2:00 mark, Leo added the featured images widget to the Home Page (below content) area. When I do that, it just doesn't show.

All three widgets (newest, similar, featured) work fine on all image pages at the bottom - I'm good with that.

Most importantly though I would like the newest and featured widgets on the front page though... :(

« Reply #8 on: April 27, 2013, 21:29 »
0
In the video: http://www.symbiostock.com/free-files/widgets_and_menus.swf

at the 2:00 mark, Leo added the featured images widget to the Home Page (below content) area. When I do that, it just doesn't show.

All three widgets (newest, similar, featured) work fine on all image pages at the bottom - I'm good with that.

Most importantly though I would like the newest and featured widgets on the front page though... :(


Same here. Probably my fault.


« Reply #9 on: April 27, 2013, 21:36 »
0
Why would it be your fault?  8)

Maybe someone who got it working can chime in how to achieve what I want to do...?

Leo Blanchette

« Reply #10 on: April 27, 2013, 22:04 »
0
Sorry I"ve been relying on everyone to help eachother while I keep working on next release :D

Have you added the images to the "Featured images" category yet?

Its possible that you have a situation left over from the "old days" before I implemented this. In that case you can delete featured images category, then reactivate your theme.

At that point you should be up to standard with all the new versions of Symbiostock, where people do not have to pull their hair out (much).

« Reply #11 on: April 28, 2013, 07:57 »
0
Sorry I"ve been relying on everyone to help eachother while I keep working on next release :D

Have you added the images to the "Featured images" category yet?

Its possible that you have a situation left over from the "old days" before I implemented this. In that case you can delete featured images category, then reactivate your theme.

At that point you should be up to standard with all the new versions of Symbiostock, where people do not have to pull their hair out (much).

Hi Leo, I really don't want to bother you with that.

I don't really have a problem assigning the featured images to the widget - it works great. The newest, similar and featured widgets work fine on the image pages.

The problem I am having is that these widgets do not show on the home page.

There was a thread where Symbiostock users were showcasing their sites. One user already has his site (illustrations) up with more than 1500 images. He has his front page filled with the newest and featured images I believe.

I wanted to create something similar by adding the newest and feature widget to my home page and possibly adding some static content underneath.

So I'm trying to add the widgets to "Home Page (Above Content)" or "Home Page (Below Content)" but no images show up.

Does this have anything to do with a custom created page set to the default home page?

To do that, in the control panel, I goto "Appearance" -> "Themes" -> Symbiostock "Customize" and in the left menu at the bottom I set my front page to be a static page.

Will this override or disable the widgets from showing up on my front page?

« Reply #12 on: April 28, 2013, 08:30 »
+2
Part of the reply is above.  I found I could get them to work best with the Homepage CTA template in Pages.  If the templates are not showing click the screen options dropdown at the top of the page and click the box to make it show.

Hope this helps


« Reply #13 on: April 28, 2013, 09:22 »
0
Tinny, you deserve 5 stars!!!

Thank you, thank you thank you!

Finally!!!!!!!!

 ;D

Now I can get to work!

« Reply #14 on: April 28, 2013, 15:38 »
0
:) you are welcome, pleased to be able to help

Microstock Man

  • microstockman.com

« Reply #15 on: April 30, 2013, 19:46 »
0
Does anyone know how to limit the amount of featured images that get displayed on the home page? For instance, I would only like 12 images to be shown on the homepage under the Featured Images widget. How can I limit it to that?

« Reply #16 on: April 30, 2013, 19:57 »
0
Does anyone know how to limit the amount of featured images that get displayed on the home page? For instance, I would only like 12 images to be shown on the homepage under the Featured Images widget. How can I limit it to that?

I think you just need to limit the number of images you tag as Featured Images to 12.   I don't think it works on a rotating basis.

Microstock Man

  • microstockman.com

« Reply #17 on: April 30, 2013, 19:59 »
0
Does anyone know how to limit the amount of featured images that get displayed on the home page? For instance, I would only like 12 images to be shown on the homepage under the Featured Images widget. How can I limit it to that?

I think you just need to limit the number of images you tag as Featured Images to 12.   I don't think it works on a rotating basis.

Yeah that would be one way.

But I'd rather be able to flag as many as I like, so that they can all be shown under the "Featured" category. But would be nice to limit how many the widget shows, sort of like the newest widget, it only shows 6 newest instead of every new image.

Leo Blanchette

« Reply #18 on: April 30, 2013, 20:35 »
0
BTW CTA simply means "call to action" there is not a more intuitive way to name it. Feel free to give me a new name for that template.

quailrunphoto

« Reply #19 on: May 10, 2013, 02:55 »
0
I have tried the different templates for the Home page and they all have the same results, the content is displayed without any of the widgets showing up.  I have tried a couple different widgets is various locations on the home page without anything happening.  I have tried the various home page templates, the default template and even the full page template, without success.
The "Reading Settings" is set to static page with "Home" defined as the Front page.

Any suggestions?

« Reply #20 on: May 10, 2013, 06:15 »
0
I have tried the different templates for the Home page and they all have the same results, the content is displayed without any of the widgets showing up.  I have tried a couple different widgets is various locations on the home page without anything happening.  I have tried the various home page templates, the default template and even the full page template, without success.
The "Reading Settings" is set to static page with "Home" defined as the Front page.

Any suggestions?

What is your page address?

quailrunphoto

« Reply #21 on: May 10, 2013, 09:22 »
0
If you mean the web address it is www.quailrunphoto.com/home

If you mean a different address please let me know.

« Reply #22 on: May 10, 2013, 10:59 »
0
If you mean the web address it is www.quailrunphoto.com/home

If you mean a different address please let me know.


For my Home page, template is "home page CTAs", i don't know if it help you.

Also, below a quick explanation of my home page setup. Maybe it can help. Theme is not SY child theme, but "Clean Theme" from our friend Amanda_k. I hope it can help you.

ps: i wrote "deside", but is "beside"

« Last Edit: May 10, 2013, 11:04 by Chico »

quailrunphoto

« Reply #23 on: May 10, 2013, 11:35 »
0
I love the look of your page.  I will try to incorporate some of those techniques into my page.

I took a step back and decided to just delete my home page and create a new one.  I had to reset the Home page link in setting, but after that everything seems to be working.  Must have been a problem in my home page setup that was not working correctly. 

Again thanks for advise.

David

« Reply #24 on: May 26, 2015, 02:35 »
0
That Screen option setting is a good option, but still if found some issue you can go with plugins. there are several plugins available for the same.

I have also used the same template to create my gallery website. By profession i am a Photo Editor at newbielink:http://www.smartphotoeditors.com/ [nonactive]. My site is under construction, once done I will definitely share with you.

« Reply #25 on: May 26, 2015, 05:40 »
-1
OLD THREAD ALERT!


 

Related Topics

  Subject / Started by Replies Last post
2 Replies
4109 Views
Last post September 11, 2007, 02:14
by sharpshot
2 Replies
2068 Views
Last post March 21, 2011, 10:38
by click_click
34 Replies
5217 Views
Last post April 22, 2013, 21:09
by cascoly
8 Replies
2718 Views
Last post August 21, 2013, 23:16
by stockphoto-images.com
3 Replies
1706 Views
Last post April 17, 2016, 10:11
by helloitsme

Sponsors

Microstock Poll Results