MicrostockGroup Sponsors


Author Topic: No meta data in Symbiostock downloads?  (Read 3152 times)

0 Members and 1 Guest are viewing this topic.

EmberMike

« on: August 04, 2013, 10:24 »
0

Just noticed that meta data stays embeded in the watermarked preview images on my site, but the downloaded files the buyers get are stripped of meta data.

Any reason for that? Is there any way to retain the meta data embeded in images?


ShazamImages

  • ShazamImages.com
« Reply #1 on: August 04, 2013, 10:50 »
0
I'm very interested in this as well.

IMO, retaining the IPTC data (especially the author/copyright) in the sold image is important in regards to protecting our copyrights.

« Reply #2 on: August 04, 2013, 10:52 »
0
I made a test purchase on 7-21-13 of a bloggee sized image and the metadata is there. This was fixed a couple of versions ago. I am still on 2.5.5 but I'm not sure why it isn't showing for you. Good question.

« Reply #3 on: August 04, 2013, 11:28 »
0
In my tests so far, metadata was missing from downloaded files that were processed with GD Library but images processed with Imagick had full metadata.

« Reply #4 on: August 04, 2013, 11:50 »
0
In my tests so far, metadata was missing from downloaded files that were processed with GD Library but images processed with Imagick had full metadata.

Yep I think you are correct. In fact, I think that was one of the reasons for implementing imagick, along with its better processing of images.

« Reply #5 on: August 04, 2013, 12:12 »
0
I made a test transaction with 2.5.6 a day or two ago, and all meta data was striped.

ShazamImages

  • ShazamImages.com
« Reply #6 on: August 04, 2013, 12:55 »
0
I made a test transaction with 2.5.6 a day or two ago, and all meta data was striped.

Is your Symbio site using the GD library or ImageMagick?

« Reply #7 on: August 04, 2013, 21:57 »
0
I haven't downloaded any of them yet. Which one should be used?
 

Leo Blanchette

« Reply #8 on: August 04, 2013, 22:04 »
0
If you have imagemagick or imagick turned on (which is php extension for imagemagick) metadata should automatically be assigned.

« Reply #9 on: August 05, 2013, 01:15 »
+1
Thanks, Leo

1. I went to my Gallery Options, and switched it from GD Library to ImageMagick. Worked fine.
2. Then I logged in as the buyer, and purchased an image. Transaction successfully completed, incl. Paypal payment.

But when I want to download the image, I get a message:
No webpage was found for the web address: http://www.advantica.com/stockphotos/wp-content/symbiostock_file_download.php
Error code: ERR_FILE_NOT_FOUND


Two days ago, when I tested my first download, everything seemed the same, and I was able to download the image.

Any idea what is the problem and how to fix it?

As a developer, I can tolerate occasional hickups. But for a buyer this would be a big frustration and turn-off.
I tend to agree with Dan that the mandatory registration will piss off some buyers. Let's make it optional.

 


Leo Blanchette

« Reply #10 on: August 05, 2013, 01:25 »
0
What version are you using? (Its missing the proper path btw)

« Reply #11 on: August 05, 2013, 01:47 »
0
I'm using wordpress 3.5 and Symbio 2.5.6 with CleanTheme 2.0

Leo Blanchette

« Reply #12 on: August 05, 2013, 01:51 »
0
edit - Nevermind - don't change anything. Give me a moment to check everything on my end first.
« Last Edit: August 05, 2013, 01:54 by Leo »

Leo Blanchette

« Reply #13 on: August 05, 2013, 01:55 »
0
Having looked at things -
Toggle the theme by turning off then on again.

Then try the download. If it still doesn't work let me know.

« Reply #14 on: August 05, 2013, 02:01 »
0
I toggled Symbiostock and then back to CleanTheme. It didn't help with the download of the completed transaction (2nd purchase). Same error message as before.
Shall I make a new purchase transaction?
 

I don't know if the following will help:
The first image purchased had a number 164. The second image was assigned number 482.
But when I click on Get Your Images / download link in the received email, I am pointed to the image 164.

BTW, are these image numbers assigned consecutive values as the images are purchased, or are hey related somehow to the actual image pages?
« Last Edit: August 05, 2013, 02:08 by LesPalenik »

Leo Blanchette

« Reply #15 on: August 05, 2013, 02:08 »
0
Unless I've missed something your the first person thats ever had this problem. You could try a new purchase, but everything should be working. If it does not work this time I'm going to have to look into it

« Reply #16 on: August 05, 2013, 02:18 »
0
3rd transaction completed and paid to Paypal.

When  I click on my email confirmation, the Customer License and Management screen displays the thumbnail of the new purchase, but the number 164 assigned originally to the first transaction from 2 days ago.
Clicking on the "Get your images here"  link, generates the same error message as before.
« Last Edit: August 05, 2013, 02:47 by LesPalenik »

Leo Blanchette

« Reply #17 on: August 05, 2013, 02:46 »
0
While we're on it, maybe a few people can do some test purchases?

This is a new one on me. I'd have to look at it to see what the problem is.

Send me an admin account leo [at] symbiostock.com and I'll check it out.

« Reply #18 on: August 05, 2013, 02:50 »
0
Leo,

I don't know what you mean by sending admin account, but I sent you a PM.

Leo Blanchette

« Reply #19 on: August 05, 2013, 02:55 »
0
no prob!

I just did a purchase and got the image no problem! 482-bloggee.jpg! Its beaauuutiful.

« Reply #20 on: August 05, 2013, 03:08 »
0
Thans for good news, Paypal refund processed.
I did it again, and the screen shows still number 164 (not 482), and I get the same problem.
It looks like it's something related to my computer session. I am going to reboot the computer now.

Leo Blanchette

« Reply #21 on: August 05, 2013, 03:20 »
0
Let me know if you've discovered a browser issue.

« Reply #22 on: August 05, 2013, 03:31 »
0
You are right, it was something with the browser or the Login session as the buyer.
I rebooted the computer, and still had the same problem. Then, I logged in to my website again (as the buyer), and this time the download worked like a charm.
However, the meta data is absent in  the downloaded file. I presume you didn't get either.

When does ImageMagick save the meta data - at the image the image is processed or when writing the purchased file?
Since I switched from GD Library to ImageMagick just today, will I have to re-process all existing images?


I just tried it again, with a freshly imported and processed file, this time definitely using ImageMagick.
The download worked fine, but I have the same problem, no metadata.


 
« Last Edit: August 05, 2013, 04:17 by LesPalenik »

« Reply #23 on: August 05, 2013, 03:44 »
0

Just noticed that meta data stays embeded in the watermarked preview images on my site, but the downloaded files the buyers get are stripped of meta data.

Any reason for that? Is there any way to retain the meta data embeded in images?

Mike, can you see complete metadata in your watermarked file?  (including the camera data).
I can see the description, keywords, and copyright, but in the camera section I see only the lens description (no other data).
 

« Reply #24 on: August 05, 2013, 09:57 »
0
I don't want to hijack this thread but... what is ImageMagick and why do we need it??

Just Googled it. Way too complicated for my ol' brain to understand.

I use LR and (as needed) Photoshop and am happy with that combination. Are you saying I now need to add ImageMagick just so my metadata will accompany my images to their destination? I really don't want to have to install and learn another program just to do something basic like that.

Advice, please!


 

Related Topics

  Subject / Started by Replies Last post
57 Replies
6673 Views
Last post May 12, 2013, 11:05
by pixel86
28 Replies
9142 Views
Last post March 11, 2016, 17:35
by fotografer
2 Replies
1102 Views
Last post February 18, 2016, 19:15
by signist80
0 Replies
1097 Views
Last post February 28, 2016, 23:11
by Rick_jo
0 Replies
570 Views
Last post September 22, 2019, 09:37
by charged

Sponsors

Microstock Poll Results