MicrostockGroup Sponsors


Author Topic: 123rf First 10 submission  (Read 4064 times)

0 Members and 1 Guest are viewing this topic.

« on: May 31, 2008, 03:52 »
0
Posted my first set to 123RF, all people-free photos.  Do I need to set the MR to 'No', or do I leave in the default blank state?


ACS

« Reply #1 on: May 31, 2008, 04:33 »
0
I set them "No" always. No problem so far..

« Reply #2 on: May 31, 2008, 04:34 »
0
Most of the time I don't change it unless I have a MR. No problems so far.

« Reply #3 on: June 14, 2008, 22:16 »
0
Question about this as well.

I submitted ten images weeks ago, probably almost a month. Is this a normal time to wait or should I be contacting support or something?


« Reply #4 on: June 14, 2008, 23:55 »
0
Question about this as well.

I submitted ten images weeks ago, probably almost a month. Is this a normal time to wait or should I be contacting support or something?



I would drop a quick note. Mine took only 1 day at beginning of April. And even lately my images are usually reviewed overnite. Stockxpert is the one that took about 12 days I think. I know it took awhile.


« Reply #6 on: June 20, 2008, 02:07 »
0
The ID was the problem.

How I missed the big purple box where it told me to upload my ID I do not know.


 

Related Topics

  Subject / Started by Replies Last post
1 Replies
4036 Views
Last post October 31, 2006, 11:34
by Bateleur
3 Replies
2160 Views
Last post October 03, 2007, 08:27
by pixelbrat
4 Replies
2254 Views
Last post July 16, 2008, 17:28
by litifeta
0 Replies
3886 Views
Last post November 11, 2011, 23:01
by gemmy12
1 Replies
1918 Views
Last post April 28, 2017, 11:27
by Niakris

Sponsors

Microstock Poll Results