pancakes

MicrostockGroup Sponsors


Author Topic: E+ Problem  (Read 4393 times)

0 Members and 1 Guest are viewing this topic.

123XXX

« on: February 11, 2011, 00:04 »
0
I changed one file to E+ 4-5 days ago already and it is still showing the old prices. Meanwhile it is still selling and so I'm losing potential income. Terrible really. The file shows as E+ but the prices are still the normal crown prices.

I think I saw something somewhere by either RM or someone else how there is a known problem and it was being addressed, but I had thought it was sorted already?

Anyway, just curious if anyone knows what is going on with E+ and what the status is at the moment?

I was going to add more E+ files, but obviously I won't at this stage. How so many things can be left to dangle like that in free fall when everyone loses money leaves me gobsmacked. Anyway, I don't want to get started again. I am just so floored at how lackadaisical and irresponsibly the whole thing is run at this point.

Also, should I send them a support ticket about it or not bother if they can't seem to fix the problem anyway?

I can't think of any other large corporate web site in the world where known problems aren't fixed in a matter of hours.


« Reply #1 on: February 11, 2011, 01:14 »
0
This is just one of the many site bugs. I don't think it's sorted although I do recall an update a while back that caught up some earlier files so they showed E+ or not correctly. I think they didn't fix the bug though, just did some sort of manual update.

As far as money issues are concerned, I have a pile of subscription sales going back two weeks that I haven't been paid for (and sjlocke's pile is 157 subscriptions as of this morning some time). Supposedly we're to see something by the end of this week - but they promised that last week and we've only got one day left of this week where they're working.

You can send them a support ticket just to keep track of it, although they may close it (that happened with a different problem earlier with mine and some others' tickets - they pointed to the forum thread as a resolution even though no money had actually been paid out).

They are floundering.

The basic search problems (type red white blue into the top search box and see the mess you get in the crumb trail box) have been there for nearly two months. They fixed some problems with the layout of my_uploads and about a week later pushed fixes for other things and the broken layout came back. That sort of thing really smells like poor development procedures with checkin/checkout of code and one person's changes overwriting someone else's fixes.

I could go on. Point is that your problem is but one of many and some very serious ones are still unfixed, so I think you may be waiting a while.

« Reply #2 on: February 11, 2011, 09:23 »
0
Had the same problem 2 weeks ago when i nominated E+ files,it takes 7 to 10 days after nomination to update new pricing on those files.

« Reply #3 on: February 11, 2011, 09:36 »
0
it's just like the people who are trying to get rid of their crown... 30 day waits have turned into 45+ 

« Reply #4 on: February 11, 2011, 10:04 »
0
Should this be added to the epic fail thread? It's just another in a looooong list. :/

lisafx

« Reply #5 on: February 11, 2011, 12:40 »
0
it's just like the people who are trying to get rid of their crown... 30 day waits have turned into 45+ 

^^Seems like this one actually works to Istock's detriment.  People are free to upload to other sites after 30 days but still being paid as exclusive. :)

123XXX

« Reply #6 on: February 11, 2011, 13:18 »
0
Many thanks everyone for your good input on this. Still showing old prices on the pic. At some point you would think they would open their wallets to hire capable IT people instead of continuing to be beaten down by contributors and buyers and jeopardizing their public image the way they have. Looking at the big picture, all of this mayhem has to be hurting business overall. They are literally losing money on that picture every time it sells at the old prices and I am sure there are thousands of others like it. I just wish they had the inclination to spend money on IT in order to get all the site problems sorted out so that they can make even more money from the site in the long run. Spend $1 to make $2. Seems like common sense to me.

« Reply #7 on: February 11, 2011, 14:11 »
0
it's just like the people who are trying to get rid of their crown... 30 day waits have turned into 45+ 

^^Seems like this one actually works to Istock's detriment.  People are free to upload to other sites after 30 days but still being paid as exclusive. :)

Seriously.  Take advantage of it.

« Reply #8 on: February 11, 2011, 14:29 »
0
it's just like the people who are trying to get rid of their crown... 30 day waits have turned into 45+ 

^^Seems like this one actually works to Istock's detriment.  People are free to upload to other sites after 30 days but still being paid as exclusive. :)

Seriously.  Take advantage of it.
--------------------------

They will probably claw back the overpayments  two months from now, once they have solved that particular problem :-(

« Reply #9 on: February 11, 2011, 14:34 »
0
Seriously.  Take advantage of it.

Exactly. Not sure I understand what the 'problem' is supposed to be here.

« Reply #10 on: February 11, 2011, 15:49 »
0
The basic search problems (type red white blue into the top search box and see the mess you get in the crumb trail box) have been there for nearly two months. They fixed some problems with the layout of my_uploads and about a week later pushed fixes for other things and the broken layout came back. That sort of thing really smells like poor development procedures with checkin/checkout of code and one person's changes overwriting someone else's fixes.

Wow - they really have something messed up.  I thought I was missing something when a basic search returned no results for me the other day until I removed some of the double keyword entries...

123XXX

« Reply #11 on: February 25, 2011, 04:40 »
0
3 weeks later and my E+ problem on that one file I mentioned still goes on. Sales are continuing to be made on it on almost a daily basis at the non E+ prices, so both myself and iStock are losing money as a result. In addition, I have a feeling I am losing some other sales as well from buyers who see it is an E+ image from the icon and don't want to pay the extra money for E+ images in general. So I am probably making both less sales and less money from the image as a result of they way the status of the image is now (E+ icon with non E+ pricing). The ideal situation would be for iStock to remove the E+ icon from the image all together until iStock can get the problem sorted out. I did write to support about it and they said they have submitted the issue as a bug to the development team, but they do not have an ETA to say when it will be rectified. In addition, I have stopped adding additional E+ images to my portfolio as I am assuming any new E+ images will have the same problem as well. Is there any thread about this issue anywhere else where it has been addressed properly and do we know if it is a global site problem that is being worked on?
« Last Edit: February 25, 2011, 05:23 by 123XXX »

« Reply #12 on: February 25, 2011, 07:28 »
0
3 weeks later and my E+ problem on that one file I mentioned still goes on. Sales are continuing to be made on it on almost a daily basis at the non E+ prices, so both myself and iStock are losing money as a result. In addition, I have a feeling I am losing some other sales as well from buyers who see it is an E+ image from the icon and don't want to pay the extra money for E+ images in general. So I am probably making both less sales and less money from the image as a result of they way the status of the image is now (E+ icon with non E+ pricing). The ideal situation would be for iStock to remove the E+ icon from the image all together until iStock can get the problem sorted out. I did write to support about it and they said they have submitted the issue as a bug to the development team, but they do not have an ETA to say when it will be rectified. In addition, I have stopped adding additional E+ images to my portfolio as I am assuming any new E+ images will have the same problem as well. Is there any thread about this issue anywhere else where it has been addressed properly and do we know if it is a global site problem that is being worked on?

Sure, the Istock F5 Epic Fail thread addresses ALL such problems on an ongoing basis. Or on the istock forum, maybe the "Site BUGS Reporting ***READ ME BEFORE YOU START A NEW THREAD***" thread.  ;)


 

Related Topics

  Subject / Started by Replies Last post
21 Replies
2742 Views
Last post April 11, 2013, 10:47
by tickstock
5 Replies
1465 Views
Last post November 03, 2013, 03:43
by Ilfede
0 Replies
1675 Views
Last post October 22, 2014, 02:28
by stocked
0 Replies
1006 Views
Last post April 14, 2015, 18:44
by Uncle Pete
3 Replies
2091 Views
Last post December 12, 2015, 04:46
by FotografieSchnabel

Sponsors

Microstock Poll Results