MicrostockGroup Sponsors


Author Topic: Stock Submitter. Can I restore old backup without losing new data?  (Read 970 times)

0 Members and 1 Guest are viewing this topic.

« on: May 17, 2019, 21:08 »
0
So, I was having trouble and uninstalled and reinstalled SS to try to fix the problem.  I have done a lot of work since the reinstall of SS, before I realized that none of my old data was there for all the images I had processed before the reinstall (several hundred images).  I have a backup from before the reinstall, but I am wondering if I can restore that old back up without changing the current data.  To make it simple, I just want to add the data from the old backup to SS without out changing the current data.  Can I do this?  How can this be done?


« Reply #1 on: May 17, 2019, 21:57 »
0
Unfortunately, that's not possible I'm afraid.
However, I don't quite understand what data did you lose exactly? Metadata of your content has nothing to do with backups as it's stored in the JPEG files themselves and will not be lost no matter what happens with the program and it's configuration.
The only information that could get lost is your release database. In that case there are several things you can try to restore it.
Please let me know what information did you lose exactly?

« Reply #2 on: May 18, 2019, 00:15 »
0
The STATUS data and all the titles, keywords and tags, is what I lost.  All the images that were uploaded and submitted to microstock sites no longer show their status in association with the sites, i.e. "Ready", "Uploaded", "Submitted".  They have not tags or other information associated with them.   So, now I have no idea which ones have already been uploaded and submitted.  It as if I had never did anything to them or submitted them.  Weeks of work gone.

Only images I have worked on AFTER the reinstall show any data or status.

« Reply #3 on: May 18, 2019, 04:04 »
0
It means that you (or other software) has either removed or overwritten the JPEG files (since the metadata is stored in JPEG files).

« Reply #4 on: May 18, 2019, 11:07 »
0
It means that you (or other software) has either removed or overwritten the JPEG files (since the metadata is stored in JPEG files).

Humm... I don't see how.  Only if moving the files from one folder to another would do this (i.e. "Submitted" folder to "Approved" or "Rejected" folders).  Does moving files to a different folder cause this?

« Reply #5 on: May 18, 2019, 14:34 »
0

OOPS!  My Bad.  I moved the files to a different folder then I remembered.  Sorry for the bother.  Thanks for the help.




« Reply #6 on: May 18, 2019, 14:38 »
0
On a side note.  I recently upgraded to the basic plan  (100 monthly uploads).  If I decide to upgrade to the next level (250 uploads a month) can I do so and have the fee applied to the basic plan (4 euro) applied towards the upgrade?

« Reply #7 on: May 18, 2019, 21:09 »
+1
On a side note.  I recently upgraded to the basic plan  (100 monthly uploads).  If I decide to upgrade to the next level (250 uploads a month) can I do so and have the fee applied to the basic plan (4 euro) applied towards the upgrade?

Yes of course, you can upgrade to another plan by paying the difference in their prices. So if you do so, 6 EUR will be charged from your account balance and you will have +150 submissions for the rest of the current 30-day period.
Please note that you won't be able to switch back to the Starter plan unless you purchase a new 3-month package because this plan is promotional.

« Reply #8 on: May 22, 2019, 12:34 »
0
On a side note.  I recently upgraded to the basic plan  (100 monthly uploads).  If I decide to upgrade to the next level (250 uploads a month) can I do so and have the fee applied to the basic plan (4 euro) applied towards the upgrade?

Yes of course, you can upgrade to another plan by paying the difference in their prices. So if you do so, 6 EUR will be charged from your account balance and you will have +150 submissions for the rest of the current 30-day period.
Please note that you won't be able to switch back to the Starter plan unless you purchase a new 3-month package because this plan is promotional.


Thanks.  One more question.   I am trying to upgrade to the newest version of SS but "Windows Defender" will not let the EXE file run.  I am using Windows 10.  Just thought you would like to know this information.


Here is a screenshot of the error I get when trying to install SS (StockSubmitterSetup_15.exe)


« Reply #9 on: May 23, 2019, 05:20 »
0
Yes it's caused by the installer being not signed.
You can ignore this warning safely, click more info and run anyway.

« Reply #10 on: May 27, 2019, 11:27 »
0
Yes it's caused by the installer being not signed.
You can ignore this warning safely, click more info and run anyway.

Hope you are having a good Memorial Weekend.  Just wanted to tell you that I installed the new SS version.  I backed up my configuration before upgrading, but I cannot restore that configuration to the new SS.  Any thoughts?

« Reply #11 on: May 28, 2019, 09:17 »
0
Hope you are having a good Memorial Weekend.  Just wanted to tell you that I installed the new SS version.  I backed up my configuration before upgrading, but I cannot restore that configuration to the new SS.  Any thoughts?

I'm not living in the US, but thank you anyway :)

Please install back the old version, restore the configuration there and then install the new version - they've fully compatible in terms of configuration unless you're using Master Password feature. If you are using it, please disable it first before installing the new version.

« Reply #12 on: June 09, 2019, 13:34 »
0

unless you're using Master Password feature. If you are using it, please disable it first before installing the new version.

How do I disable the master password?

« Reply #13 on: June 09, 2019, 20:01 »
0

unless you're using Master Password feature. If you are using it, please disable it first before installing the new version.

How do I disable the master password?

Click the button to set up the master password in settings and enter an empty one.

« Reply #14 on: June 09, 2019, 21:02 »
0

unless you're using Master Password feature. If you are using it, please disable it first before installing the new version.

How do I disable the master password?

Click the button to set up the master password in settings and enter an empty one.

No such button exist that I can find.  Can you give me a screenshot of it?

« Reply #15 on: June 09, 2019, 23:46 »
0

unless you're using Master Password feature. If you are using it, please disable it first before installing the new version.

How do I disable the master password?

Click the button to set up the master password in settings and enter an empty one.

No such button exist that I can find.  Can you give me a screenshot of it?

It's on the Features tab.
If there is no such button then you've probably restored a worker configuration archive previously.
In this case there is no way to disable it and you need to get a new worker configuration archive from the person who gave you the previous one.

« Reply #16 on: June 10, 2019, 09:16 »
0

unless you're using Master Password feature. If you are using it, please disable it first before installing the new version.

How do I disable the master password?

Click the button to set up the master password in settings and enter an empty one.

No such button exist that I can find.  Can you give me a screenshot of it?

It's on the Features tab.
If there is no such button then you've probably restored a worker configuration archive previously.
In this case there is no way to disable it and you need to get a new worker configuration archive from the person who gave you the previous one.

None of what you said here is true in my case.  I don't work with anyone else, so I don't have a "Worker" configuration. Mine is a full backup.  There is no button under "Features" tab. The features tab is blank except for "Autosave".

This is a brand new installation of the Legacy version, to which I am trying to restore a full backup that was made on the Legacy version that was "Working" on this computer BEFORE I tried to upgrade to the new version.  After weeks of trying to get the New version working without success, I uninstalled the New version, did a complete computer and registry clean up and installed the Legacy version, and tried to restore the backup I made before I upgraded.  The restore process does nothing or it fails with an error.  I did have a master password set on the original installation that I made the backup with.  Earlier on this thread, you told me that I needed to turn the Master Password function off before restoring.  But that option is not available to me.


I know you are trying to help, but at this point, NOTHING is working and I am completely unable to use the program for any purpose. I do appreciate your willingness to respond and try to help, but everything you have said so far about my problem has been inaccurate and has not helped me at all.  The program appears to be doing things that not even you understand and that gives me very little encouragement to continue using it.

« Reply #17 on: June 10, 2019, 10:11 »
0
Okay.  Since I could not get the legacy version to work, I decided to try the New version again.  After an uninstall of the old version and PC clean up, I downloaded the New version and installed it.  Of course, I had to get past the windows "Invalid Certificate" warning (you really need to fix this.  Security is important these day). 

Upon launching the fresh install of the new version, it downloaded the 425 program differences. It came up to the login screen and already had my account information prefilled in the fields.  So this means that the program is storing this information on my PC somewhere that it is not deleted when you uninstall the old program.  I ran a feel system cleanup cleaning all catches and histories before installing the program, so that is not where this information is stored either.  I also ran a registry cleanup and fixed all errors, so it is not stored in the registry where Ccleaner can find it.

 So, I clicked on the, "Start Without Registration" option.  I was then presented with the "Master Password" window.  I typed in "RESET" and clicked OK.  The program launched.  I closed the program and restarted it. 

The program launched, this time the login boxes were empty and "Start Without Registration" was selected.  I clicked OK.  The program started without asking for the Master Password.  I tried to restore a backup I made with the NEW version I made on 06/09/2019, before I uninstalled it to install the legacy version.  This backup included all of the login information for the agencies I have accounts with.  The program closed and did not restart. 

I manually restarted the program.  My correct information was prefilled on the login screen.  I logged in with my account.  I was asked for the master password.  I entered it and logged in. No agency or any other information was restored. 

I entered my Shutterstock account information in under Settings/Agency' Setting and clicked saved.  I selected the checkbox next to Shutterstock under SUBMIT, and clicked the submit button.  That brought up the Shutterstock Captcha, which I completed and click okay.  The processed finished but did not import my earnings total from my shutterstock account.

I closed the program and restarted.  Upon restart, my shutterstock account information was gone and the program was back to like a fresh install.



Okay.  This is not good.  I am working my butt off trying to get this dang program to work and it refuses to work, no matter what I try.  Getting very frustrated here.  I am spending more time trying work out problems with your program then if I was uploading pictures manually.  It is costing me time and money (loss of earnings).

« Reply #18 on: June 10, 2019, 22:25 »
0
I understand your frustration but we couldn't really do anything to avoid this issue with the master password, it's because of the encryption library encrypting stuff differently depending on something that's out of our control. So the new version cannot decrypt passwords encrypted by the old version even with the correct master password :(

Could you contact me on Telegram Netherspite or e-mail mephisto123@gmail.com so we could resolve those issues more quickly?
Forums are not really a fast way to do it...


 

Related Topics

  Subject / Started by Replies Last post
6 Replies
2581 Views
Last post November 10, 2016, 09:33
by Niakris
14 Replies
6042 Views
Last post March 07, 2017, 01:03
by oz@n
11 Replies
5624 Views
Last post October 31, 2017, 05:32
by Niakris
3 Replies
1066 Views
Last post February 16, 2019, 16:05
by izzikiorage
0 Replies
244 Views
Last post May 16, 2019, 23:38
by thenatureguy

Sponsors

Microstock Poll Results