MicrostockGroup Sponsors


Author Topic: Author page disappears with child theme?  (Read 3792 times)

0 Members and 1 Guest are viewing this topic.

Poncke v2

« on: June 03, 2013, 12:47 »
0
Hi all,

I decided to start all over again as I lost the Author page and the possibily for users to fill out their author page.

So I started from scratch, deleted WP and SY, reinstalled everything. The author page was back. Just installed the child them and activated it, and now the author page is gone again.

Also when I deactivate Child and reactivate Parent, its not coming back.

1. Do I need the Child theme as I dont understand what its adding to my site.
2. How can I reinstate the author page and enable the SY extension on the user page.

If I am not clear, just let me know and I will explain differently

Thank you


« Reply #1 on: June 03, 2013, 14:18 »
0
Users do not need author pages, you are the one putting images on your site, not them.  All users need to do is buy images and stop making spam registrations and comments :)


Child theme - if you make any css changes etc it is best to do them using the child theme otherwise they will be lost everytime there is an upgrade (which there is likely to be while we are still in beta)

Fill in your details again and save them to get symbiocard/author page

Poncke v2

« Reply #2 on: June 03, 2013, 14:37 »
0
I cant because those fields are gone. And I am not going to reinstall the site again  :)

That author page /author is returning an Oops! so I dont know what happened, but I think its a bug.

« Reply #3 on: June 03, 2013, 15:09 »
0
Fill in  your details in Users, Profile this will create your symbiocard.  I believe your author page is generated from this, if it won't appear at all check your plug-ins as for some of us who started with V1 we had to reset Yoast - if you list your site it makes it easier for others to have a look and see if they can see anything obvious going on to help with answering

Poncke v2

« Reply #4 on: June 03, 2013, 15:30 »
0
I know, but I dont want to post my links here. I have never linked to any of  my portfolios before here. Haha.

« Reply #5 on: June 03, 2013, 16:46 »
0
I know, but I dont want to post my links here. I have never linked to any of  my portfolios before here. Haha.

If you want to profit from the networking abilities of Symbiostock you must overcome your aversion of linking to your portfolio, I guess. ::)

« Reply #6 on: June 03, 2013, 17:14 »
0
Users do not need author pages, you are the one putting images on your site, not them.  All users need to do is buy images and stop making spam registrations and comments :)


Child theme - if you make any css changes etc it is best to do them using the child theme otherwise they will be lost everytime there is an upgrade (which there is likely to be while we are still in beta)

Fill in your details again and save them to get symbiocard/author page

Be aware though, I am using the Clean Theme child theme and every time I upgrade the parent SY theme, my custom CSS disappears and I have to add it back to the child theme CSS Edits tab.

Poncke v2

« Reply #7 on: June 03, 2013, 18:03 »
0
I know, but I dont want to post my links here. I have never linked to any of  my portfolios before here. Haha.

If you want to profit from the networking abilities of Symbiostock you must overcome your aversion of linking to your portfolio, I guess. ::)
I know, and I will, I am going to close this account here and come back under another name. Has to happen at some point.

travelwitness

« Reply #8 on: June 03, 2013, 18:26 »
0
I know, but I dont want to post my links here. I have never linked to any of  my portfolios before here. Haha.

If you want to profit from the networking abilities of Symbiostock you must overcome your aversion of linking to your portfolio, I guess. ::)
I know, and I will, I am going to close this account here and come back under another name. Has to happen at some point.
No bad thing :-)

« Reply #9 on: June 03, 2013, 19:31 »
0
I cant because those fields are gone. And I am not going to reinstall the site again  :)

That author page /author is returning an Oops! so I dont know what happened, but I think its a bug.

when  you get an 'oops', go back  one page and see what page it was trying to read, then see if that page is in your list of pages.  earlier there were some problems with eula and category pages that were fixed this way.

« Reply #10 on: June 03, 2013, 19:53 »
0
Users do not need author pages, you are the one putting images on your site, not them.  All users need to do is buy images and stop making spam registrations and comments :)


Child theme - if you make any css changes etc it is best to do them using the child theme otherwise they will be lost everytime there is an upgrade (which there is likely to be while we are still in beta)

Fill in your details again and save them to get symbiocard/author page

I just tried this with the Demo site and the custom css remained in place.  If it's getting deleted on your site we may need to look at how you are upgrading, are you deleting the child/parent themes before installing the new version?  I just clicked upgrade in the theme panel on the parent theme with out activating it and nothing was deleted or changed in my custom CSS panel in the child theme.

Be aware though, I am using the Clean Theme child theme and every time I upgrade the parent SY theme, my custom CSS disappears and I have to add it back to the child theme CSS Edits tab.

« Reply #11 on: June 04, 2013, 00:25 »
0
Hi Amanda,
The only time my child theme was affected during an update was a while ago when leo warned us  that some of our changes might be lost, to the footer I think, otherwise my child theme stays intact without having to deactivate it during updates. Yours is much more detailed than mine though :)

« Reply #12 on: June 04, 2013, 05:38 »
0
I never delete the child theme. My process was to activate one of the twenty themes, delete parent theme, install upgrade, reactivate child theme. Thats the process that was recommended until recently.


This last update i did...leo has upgrades available in the theme panel. I clicked on the upgrade icon, then decided to work on a couple of things first so went to another page. Then the upgrade option disappeared so i did the upgrade as before.


But my css disappeared before leo incorporated the new upgrade icon. I did the upgrade just as before, only deleting parent theme, yet child css disappeared.


I see there are more upgrades, so i will give it another shot with the theme upgrade button, now that i have css backed up.


Regardless of how i upgrade the parent theme, i dont get why the child theme was even touched. I thought that was the whole point of having the child.

« Reply #13 on: June 04, 2013, 05:49 »
0
I am probably wrong but I think when I was having problems changing something, someone said you need to add the files that (for instance) header calls on to the child theme as well, but Leo mentioned there was another way of doing it that he could implement.  Maybe he implemented it?   I only lost changes to my child theme once and I think that was to the footer during one of the major upgrades

« Reply #14 on: June 04, 2013, 14:05 »
0
Oh I see, just for future reference you  don't want to switch pages or try to do other things while the theme is updating.

« Reply #15 on: June 04, 2013, 17:54 »
0
Oh I see, just for future reference you  don't want to switch pages or try to do other things while the theme is updating.

No, I didn't start the upgrade, I just went to the page to upgrade. Then the little circle upgrade symbol disappeared. But no matter. I just upgraded to 3.4.1 using the upgrade button in themes, and it worked just fine. So all is well.

Poncke v2

« Reply #16 on: June 05, 2013, 12:02 »
0
I am still not sure what to do? My author page and symbiostock card fields are still awol. Any ideas on how to get them back? Thank you.

« Reply #17 on: June 05, 2013, 13:34 »
0
Have you filled in the details in User - Profile

Poncke v2

« Reply #18 on: June 05, 2013, 13:43 »
0
Have you filled in the details in User - Profile
Yes, but those are the standard WP fields. I am missing the SY card fields.

Leo Blanchette

« Reply #19 on: June 05, 2013, 14:10 »
0
Did u log in as the admin that sells the images? That is assigned in network area

« Reply #20 on: June 05, 2013, 14:34 »
0
Just to be sure (because there are a couple of spots that might be confused for each other) you go to the main Symbiostock Network tab and you fill out those options, then be sure to click here:



And fill out the options there as well.  Oh and like Leo said make sure you are logged in as the admin/uploader.

Poncke v2

« Reply #21 on: June 05, 2013, 15:36 »
0
Did u log in as the admin that sells the images? That is assigned in network area
Yes, I am signed in as admin.

Poncke v2

« Reply #22 on: June 05, 2013, 15:40 »
0
Just to be sure (because there are a couple of spots that might be confused for each other) you go to the main Symbiostock Network tab and you fill out those options, then be sure to click here:



And fill out the options there as well.  Oh and like Leo said make sure you are logged in as the admin/uploader.


I am not seeing that. I dont have the child theme activated by the way

when I go here  /wp-admin/admin.php?page=symbiostock-control-options I dont see whats in your screenshot.

« Reply #23 on: June 05, 2013, 15:49 »
0
Do you have the network activated?  I just looked on my test site and when the network is not activated you will not have those options.

Poncke v2

« Reply #24 on: June 05, 2013, 16:44 »
0
CR@P !!! I switched that off because the site was in work mode. LOL.

But I still dont have those fields back and the author page still returns an Oops!

« Reply #25 on: June 05, 2013, 16:59 »
0
Hmm, I'm not 100% on this, but try checking this box:



And then make sure you scroll down to save changes. 

Leo Blanchette

« Reply #26 on: June 05, 2013, 17:29 »
0
I guess the only thing I can think is that your not using the most current version. Its very strange your not seeing that.

Poncke v2

« Reply #27 on: June 05, 2013, 17:32 »
0
Ok  I got that sorted now. We were referring to different pages.   :)

I was referring to the user profile page, where I also would have the symbio fields, after the WP fields.

But I think I have it sorted now via your solution. I have the author page back now. And I have my simbiocard. Thanks for that.

Now I just need to figure out how to change the word Info under the image to Semmick Photo and change the avatar of the Symbio ladybug to my own avatar

« Reply #28 on: June 09, 2013, 15:31 »
0
I can't find an author page either -- I have yoast SEO, and the symbiocard generates fine, but I can't find any author page

also, is there a generic contact page?
« Last Edit: June 09, 2013, 15:33 by cascoly »

« Reply #29 on: June 09, 2013, 15:45 »
0
Does resetting Yoast to default bring it back?

« Reply #30 on: June 09, 2013, 16:01 »
0
There isn't a generic contact page, that's one everyone needs to create.  What was your link again? sorry!  You do have the network feature turned on right?

« Reply #31 on: June 09, 2013, 17:14 »
0
There isn't a generic contact page, that's one everyone needs to create.  What was your link again? sorry!  You do have the network feature turned on right?


http://cascoly-images.com/pix/author/steve@cascoly.com/  is my author page -- not sure if it was there before & I just cou;ldnt find it - I just guessed at the url based on other people's, then added it as a custom url to the menus

networking is working fine


 

Related Topics

  Subject / Started by Replies Last post
4 Replies
1617 Views
Last post March 30, 2013, 03:28
by Kerioak~Christine
43 Replies
4418 Views
Last post July 10, 2013, 20:38
by cathyslife
3 Replies
1042 Views
Last post April 30, 2013, 03:51
by Kerioak~Christine
111 Replies
12442 Views
Last post August 30, 2013, 17:19
by cathyslife
1 Replies
1186 Views
Last post September 14, 2013, 16:50
by DallasP

Sponsors

Microstock Poll Results